rubygemからインストールできるtomdocは古い

  • 2013年6月16日 00:04
  • ruby

itunes-clientのドキュメントを勉強がてらtomdocのスタイルで書こうとしてたら、全く動かない。パースに失敗してる感じ。

$ tomdoc lib/itunes/track.rb                                                                                                                         
--------------------------------------------------------------------------------
Itunes

coding: utf-8

コメントが構文エラー起こしてるのかなぁ、、と思ってたら同僚の中村氏がさらっと気になる発言をしてた。

まさか、、と思って最新版をcloneしてそっちの実行ファイル経由で実行してみたら確かに通りました。

$ git clone https://github.com/defunkt/tomdoc.git
$ cd itunes-client
$ ../tomdoc/bin/tomdoc lib/itunes/track.rb 

Itunes::Track.find_by(arg)

Public: Find some tracks by conditions.

Examples

  Track.find_by(name: 'Hello, Goodbye')
  # => #[<Itunes::Track:0x007fd02213fc78 @album="1">, <Itunes::Track:0x007fd02213fc79 @album="Anthology2">]

  Track.find_by(name: 'Hello, Goodbye', album: '1')
  # => #[<Itunes::Track:0x007fd02213fc78 @album="1">]

Returns an array including found tracks.
--------------------------------------------------------------------------------
...

なぜこの最新版がgem化されてないのかは謎ですが、tomdocの利用時には注意しておいたほうが良さそうです。

関連広告

Trackbacks:0

TrackBack URL for this entry
http://blog.katsuma.tv/mt-tb.cgi/260
Listed below are links to weblogs that reference
rubygemからインストールできるtomdocは古い from blog.katsuma.tv

Home > ruby > rubygemからインストールできるtomdocは古い

Search
Feeds

Return to page top